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Module Goals – taken from the Module 5 ICDL Syllabus
Module 5 Database requires the candidate to understand some of the main concepts of databases
and demonstrates the ability to use a database on a computer. The candidate shall be able to create
and modify tables, queries, forms and reports, and prepare outputs ready for distribution. The
candidate shall be able to relate tables and to retrieve and manipulate information from a database
by using query and sort tools available in the package.

Introduction
Databases are much like spreadsheets with information organized and stored in a series of tables
with rows and columns. However, databases are more powerful than spreadsheets in the way that
data is manipulated. You can do more complex searches or calculations, for example. BASE is
similar to MS Access.
The main commands used to control databases are based on the American Industry Standard ANSI
SQL, or Structured Query Language. This language defines the commands used to create a database
and manipulate the contents. OOo BASE provides a built-in HSQL engine which offers features for
creating basic to advanced database tables, forms, queries and reports.
With OOo BASE, you can:
✔ Create, modify, update tables
✔ Create indexes for the data tables for easier access
✔ Create professional looking forms and reports
✔ Perform simple or complex searches and sorts
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5.1 Using the Application
5.1.1 Database Concepts
Understand what a database is.
A database is a file which contains a series of related information, organized into rows and columns.
A typical example of a database is a telephone directory or an address book. It consists of a large
table with a series of cells/rows/columns into which data (information) is entered and processed. It
is sometimes also referred to as a Data Source.
Understand how a database is organized in terms of tables, records, fields, and with field data
types, field properties.
The basic format for a database is a table, consisting of rows and columns. Each row in the table
contains specific related information. For example, a row may contain the name, address, telephone
number, etc. for each employee in an office. Each row is called a record, and each record contains
specific information for one person in the office. A database can have more than one table.
Each row will consist of a number of cells, or fields. Each field has a specific piece of information.
For example, there would be a field for the first name, a field for the last name, a field for the
address, etc. Within each field there are different field data types. For example, the name fields
could be text fields, while the telephone/fax fields could be numerical only.
Each field can have specific field properties, such as whether it is compulsory to add data or
whether the field can remain empty. For example, the name fields must contain data, but the fax
entries can remain empty because while everyone has a name, not everyone has a fax number.
Understand what a primary key is.
A primary key is assigned to each record and helps to identify the records in a database.
Each primary key is unique for each record. In other words, the there is a different 'key'
for each record. OOo lets you choose whether to make a specific field the primary key
field, or to create an ID Field, or you can create it manually or let the program generate an
automatic primary key for each record.
Understand what an index is.
An index helps you quickly find information in a database by providing specific information related
to the records. When a sort is performed or a table is linked to another table, OOo uses 'indexes' for
the function. A primary key is a typical index and is created automatically in a table. Additional
indexes can be created based on any field in a database.
Understand the purpose of relating tables in a database.
In relational databases information is stored in separate tables and then 'relationships' are created to
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link the tables and allow you to manipulate the related information. Another type of database is a
flat file database, which basically consists of one table. They are not usually used to store large
amounts of data, and are more commonly used for small lists, such as an address list.
Understanding the importance of setting rules to ensure relationships between tables are
valid.
When setting up a database, it's important to define the fields properly so that when relationships
are established between certain fields the correct information is obtained. For example, in the name
field it is important that only text can be entered in the field. In the telephone field, only numeric
entries should be allowed. In this way only the correct information can be entered into a field,
which gives more accurate results.

5.1.2 First steps with Databases
Open and close a database application.
To open the database application in OOo (BASE), go to Start>Programs>OOo>BASE, or if
OpenOffice.org is already open, go to File>New>Database. The Database Wizard appears.

To open an existing database, click in the Open an Existing Database file box and select a database
from the list. To connect to an existing database not created in OOo, click on Connect to an existing
database and make a selection. Follow the prompts to Register, Save and Open. (See below.) To
close the application, go to File>Exit.
Open, log on to an existing database.
To open an existing database, go to File>New>Database. In the Database Wizard window, choose
Connect to an existing database file. Select the type of file and click on Next. In the next screen of
the Database Wizard click on Browse and navigate to the file. Click on Open. The next screen of the
Database Wizard appears and you will be prompted to Register the database. If you need to edit the
tables, click on Open for Editing, but normally you can deselect this item. (Note: the Database
Wizard will open different windows, depending on the type of database you have chosen to open.)
Click on Finish.
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The Save As dialog box appears and you need to enter a new name in the File name box. Saving in
this screen allows OOo to create a new file which is saved and registered in BASE format. The
extension .odb is automatically added to the name of the file.
Once a database has been 'registered', you can open it by going to File>Open and selecting it. Click
on Open. In the next screen, double-click on the Table name to open it.
Note: if you start the BASE module you will only have two options – you can create a new
database or register and work with a database created in another application. You can open a
database in other modules of OOo by going to File>New>Database, or you can open a registered
database (see below) by going to File>Open.
Create a new database.
Go to File>New>Database. The Database Wizard opens. Select Create a new database. Click on
Next. Select Yes, register the database for me. Next, select Open the database for editing. This lets
you open the file to enter data. Select Create Table using Table Wizard. Before you can work with a
database you must create a table, so this allows you to format a table to work with. Click on Finish.
You will be prompted to save, and then continue designing the table (see below.)
Save a database to a location on a drive.
Once you create a database using the Database Wizard, you will automatically be prompted to save
it. In the next screen, the Save as... window opens where you need to give the database a name and
save it. If you are saving in the default directory, you only need to name the file and click on Save.
If you area saving to a different directory, select the directory from the Save in box first, then click
on Save. Once you begin working in the database you can save by clicking on the Save icon or
going to File>Save, or by pressing CTRL+S.
Creating a database, continued...
In the next screen you will be prompted to select a Category for it (Personal/Business.) Next,
choose a Sample Table, then choose Fields to Use. In this option, select a field under Available
Fields and then click on the right arrow (>) to add it to the list on the right. To move a field
up/down in the list, select it and use the up/down arrows. The fields in the database will appear in
the order you create in this list. Normally the first field in the list is used as the Primary Key. You
will be prompted to assign this later. Note: if the field names aren't exactly what you need you can
modify them later. Click on Next.
In the next screen you need to set the Field Properties. Choose a field from the Selected Fields list
and then change the Field Name/Type to suit your needs. When you have finished assigning
properties to each field in the list, click on Next. For example, if you chose Customer ID as a field,
you could change its name to Employee ID at this point.
You now need to assign a Primary Key for the database. This makes it easier to link information in
various tables. Select the Create a Primary Key box. If you entered a field to use as a Primary Key
when you were selecting fields to use, then choose Use an existing field as a Primary key and
ICDL & OOo BASE

5

Module 5 - Databases

OpenOffice.org
choose the name from the Field Name list. If you have not created a field to use as Primary key,
then select Automatically add a primary key. Enable the AutoValue button. This lets BASE create a
field with a unique number for each record. Click on Next.
In the next screen, name the table. Select Insert data immediately or Create a form based on this
table. The first option lets you enter data using the List view, and the second option lets you enter
data using a form.
List View – this style is usually used with simple forms and looks like a Calc spreadsheet. The fields
are shown as columns, and each row forms a record. You add the information in a list of rows.
Form View – in this view each record is shown individually. In other words, each record appears as
a page. Choose a view and click on Finish.
Note: the Database window automatically opens with Forms selected. Click on Tables to view the
table you have just created.
Using available Help functions.
OOo offers context related Help features, so when you are working in BASE you can get related
information. Each dialog box in the Database Wizard has a Help button, or you can click on Help in
the Menu Bar once you begin working in the database. If Help does not automatically open in the
BASE mode, you can switch to it using either the drop-down list in the Title Bar or click on a
category in the blue list in the right side of the window.

Close a database.
Click on File>Close or use the 'X' at the top right corner of the screen. You will be prompted to
Save, Discard or Cancel. Save any added material, if needed. If you Discard, nothing will be saved
that was added since your last save. Once you select either Save or Discard the file will close. (To
cancel the command and return to the document, select Cancel.)

5.1.3 Adjust settings
Change between view modes in a table, form, report.
In the Database Wizard you can choose whether to view your file as a table, a form or a report.
Select the option needed. For a report, you will need to use the Report Wizard to create it first, by
selecting the appropriate fields to display, background colour, etc.
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Display, hide built-in toolbars.
The toolbars in BASE work the same as in other OOo modules. Go to View>Toolbars and select
the toolbars to show or hide. Toolbars which have a checkmark beside them are open, those with no
checkmark are closed. You can also click on the drop-down arrow to the right of any toolbar and
select Close Toolbar. You will need to use the View>Toolbars option to restore it.
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5.2 Tables
5.2.1 Main Operations
Create and save a table and specify fields with their data types.
Following the directions above you have created a database and saved it. The Wizard automatically
creates a table which you can begin to use for data entry.
To create a new table using the Wizard
In the Database window, select Tables>Use Wizard to Create Table. Follow the steps. You can
have multiple tables in a database. When you have finished creating the table it will be listed in the
Database window if you have selected Table view. You can either double-click on it to open the
file, or right-click and choose Open. To modify fields, right-click on the table name and select Edit
(see below.)
To create a new table in Design View
In the Database window click on Tables>Create Table in Design View. A new empty table will
open. The first thing to do is create the fields for the table and set the properties. Type the name of
the first field, such as Employee ID. As soon as you begin to type a new section will open in the
bottom half of the window to allow you to define field properties. To choose the Field Type, click
in the box next to the Field Name. A drop-down arrow lets you open the list to choose the type of
entry, such as text or numeric. In the lower pane choose whether an entry is required and the length
of the entry. If this is the field to be used as a Primary Key, right-click in the grey area and select
Primary Key.
Repeat entries and selecting field properties until you have a list of fields for the table. In this
window you can insert extra rows as you are designing the table. Right-click in the grey area under
where the new row should be inserted and select Insert Rows. Note: once you have created the table
and saved you can only insert rows after the last field selection. You will need to Cut and Paste in
order to insert a row between fields at this stage, so it's better to make a list of the fields you need
now, so you won't have to worry about inserting extra fields later.
Save, name the new table and close. In the Database window you will see the new table. Right-click
and select Open or double-click on the name. The new table will open and you can begin entering
data. The fields created in design view will be shown. As you enter the information for each record,
it will automatically be saved when you move to the next new record. If the columns are too narrow
to display your entries, click on the black line in the grey area between the field names and drag the
line to make the field wider.
To change the fields or properties, right-click on the table name in the Database window and select
Edit. This will open the table in Design View, where you can make changes.
Display file content.
Sometimes when there are several tables you may forget what the content is in each one. To have a
display of each table, click on the drop-down arrow beside the word None in the pane on the right
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side of the window next to your list of tables. Your options are None/Document. Select Document
and the the first part of your table will be displayed. Click on each table name to see the content.

Add, delete records in a table.
When the table is created it opens with one row where you can add the information for the fields. If
you have chosen a Primary Key with an Auto Value, the number for each record will be entered as a
record is created. When you begin to type data into the fields a new row will be created
automatically. Once all of the information for a row is complete, you have added a record. To add
another record, move the cursor to the beginning of the next row. Each time you complete a row,
another empty row will be created for new entries. You can move between cells using the mouse,
the arrow keys on the keyboard or the tab key. Once you move to the next row the record is saved,
but you can also click on the Save button when you have finished entering a record.
To delete a row, move the cursor to the grey box to the left of the record and right-click. Select
Delete. Information in a database table is saved automatically when you close the file.
Add a field to an existing table.
Once a table is created, you may find you need to add more fields. In the Database window, choose
Table and right-click on the table name. Choose Edit. A list of your fields is shown. Click in the
row under the last field entry and then type the new field name. Define the field properties and click
on Save.
To enter a field between existing fields you will need to cut and paste fields until they are in the
right position. When you right-click in the grey area to the left of any row you have the option to
insert a field, but it automatically goes to the end of the list.
Add, modify data in a record.
In the Database window, select the table and right-click. Choose Open. Select the record/field to be
modified and type in the new information. Note: when you click on a field the first time all of the
text in the cell is selected. If you press any key it will be deleted (use Undo if this happens). To
modify or correct text in a cell, click again to deselect and make changes. Click on Save and
continue with changes to each record/field as needed.

ICDL & OOo BASE

9

Module 5 - Databases

OpenOffice.org
Delete data in a record.
In the Database window, select the table and right-click. Choose Open. Select the record/field to be
deleted. To delete a record, click on the grey box to the left of the record, right-click and choose
Delete. To delete data in a record, select the field and press Backspace or Delete.
Use the Undo command.
You can go back a step if you make a mistake. Click on the Undo button to return to a previous
step, or go to Edit>Undo. Keyboard Shortcut: CTRL+Z. In some cases you can Undo more than
one step. Click on the drop-down arrow to the right of the Undo icon and select the step to remove.
Navigate within a table to next record, previous record, first record, last record, specific
record.
There are several ways to navigate to various records inside a table.
•
use the keyboard arrow keys, the tab key or the mouse to move about in a view area.
•
to locate specific records in a small database, use the arrow keys on the Status Bar under the
database, and scroll through to find a record. The right/left arrows will move one record at a
time, to the previous or next record. The arrow keys with a line will take you to the first or
last record.
•
to search records for specific data, use the Find Record icon (binoculars) from the Table
Data or Form Design Toolbars. This is similar to the Find / Replace function in Writer.
Delete a table.
In the Database Table window, select the table. Right-click and select Delete. Click on Yes to
confirm that you want to delete the table.
Save and close a table.
When you enter data into a record or make modifications, the Save button is active. When you
move to the next record, the Save button is greyed out. OOo automatically saves a record once you
complete the row and move to the next line. However, while in the record you can click on the Save
button to confirm the data is saved. To close the table, go to File>Close. You will be prompted to
save if there are changes that have not been saved. You can also click on the 'X' in the top right
corner of the window.

5.2.2 Define keys
Define a primary key.
A primary key is assigned to each record and helps to identify the records in a database. Each
primary key is unique for each record. In other words, the there is a different 'key' for each record.
OOo lets you choose whether to make a specific field the primary key field, or to create an ID Field,
or you can create it manually or let the program generate an automatic primary key for each record.
You will be prompted to create a primary key when you create a database in the Database Wizard.
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Index a field with, without duplicates allowed.
Indexes help speed up searches inside databases. BASE automatically indexes some fields, such as
the primary key field. To create your own index, in the Database window, select the table and rightclick. Select Edit. In the Edit screen, click on the Index Design icon or go to Tools>Index Design.
The first icon in the Indexes window is New Index. When you click on this icon a new index is
created in the box on the left. Since it is your first index, it will automatically be called Index 1. To
change this name, highlight this text and type a new name, such as Employees. In the box on the
right, click on the drop-down arrow and select a field to use for the index. Choose the sort order –
Ascending/Descending.
Duplicate Entries
If the field has unique entries, such as telephone numbers, you can select the box next to Unique.
This prevents duplicate entries. However, if you are using City or Last Name as an index field, there
may be several people with the same last name or living in the same city. In this case, you do not
want to select Unique, because you need to allow duplicate entries. When you have made your
selections, click on the Save icon, which is the second from the right.
Inside the Index Design window there are icons to Delete or Rename the
Index you have created. You can also Reset a selected index to its default
setting before you made changes. Save any changes.

5.2.3 Table Design / Layout
Change field format attributes, such as: field size, number format, date format.
After a database has been created you may need to change some of the attributes for the field
names. In the Database window, right-click on the table name and select Edit. In the Edit window,
the field names will be listed in the order they appear in the table. In the next box you will see the
Field Type. In the grey area at the bottom you will see the properties (attributes) that have been
assigned to them. The yellow key in the grey area next to the field name indicates that this field is
set as the primary key.
•
To change the size of a field, click on the grey box next to it to select it, then click in the box
in the grey area next to 'Length'. The current number will tell you how many characters can
be typed in the field. Enter the number of characters required to change the size.
•
To change the field format, click on the drop-down arrow next to field in the the Style box.
Select a format. For example, in the Telephone # field you could restrict the entries to
numbers, so you would select Number {Numeric}.
•
To change the number format, click on the grey box to the right of the Format example box.
This will open the field format window, where you can choose a specific number style.
•
To change the date format, click on the grey box to the right of the Format example box.
This will open the field format window, where you can choose a specific date style.
•
To change text formatting for alignment or language, click on the button to the right of the
Format Example box in the grey area under Field Properties at the bottom of the screen.
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Understand consequences of changing field size attributes in a table.
When a field is originally created, there is a specific number of characters allowed to be entered.
Sometimes you need more space, and adjusting the fields size to make it larger allows more text
entry. However, if you make the field size smaller than the amount of text you need to enter, you
will lose some of the text. For example, if you had set up the field to accept 25 letters for a First
Name, only 25 letters would be allowed in any cell in that field. If you make the field size smaller,
to 8 characters, any names longer than 8 letters would lose the end of the name. (The name
Bartholomew would appear in the field as 'Bartholo'). Make sure the field size is appropriate for its
use so that you don't lose any data entries.
Create a simple validation rule for number, text, date/time entry.
When data is entered into a field, it is necessary to make sure it is correct. Since in many cases more
than one person will enter data into a database, you can set validation rules which limit the
possibility of errors occurring. The database will not accept entries that do not meet the rules.
Data entered into a field can be defined by a set of criteria which limits the input. For example,
setting the Format Style for numbers in the Telephone field is a type of validation rule. When data
is entered, you will get an error message if text is used instead of a number, ie: using the letter O
instead of the number 0.
To set a validation rule, right-click on the table name and select Edit. For each field, select a Format
Style related to the field type, such as Text for names. Save any changes.
Change width of columns in a table.
With the table open, move the mouse cursor over the separator lines in the field name area. When
the mouse cursor changes to arrows, drag the line to make the column wider/narrower. Widening a
column will let you see any hidden text. Double-clicking on the separator line will make the column
narrower. To set a specific width, right-click on the field name and select Column Width.
Move a column within a table.
Moving a column in BASE is a little complicated. In the Table Edit menu, click on the field name
to be moved, then right-click and select Cut. Move the cursor to the bottom of the field names and
select Paste. Sometimes this does not work well and you may have to cut and paste fields that are
before the new field to a location after the new field to get it in the correct order. Save changes.

5.2.4 Table Relationships
Create a one-to-one, one-to-many relationship between tables.
When you 'link' a field in one table to an identical field in another table you create a 'relationship'.
Take, for example, a large organization with several offices. Each office has its own office manager
with a unique identification. A table exists for each office. By linking the Office Manager fields,
you can create a link between all of the office managers in your tables. A one-to-one relationship is
created between identical records in one or more tables.
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•
•

One-to-one relationships link a single record in one table to an identical record in one or
more tables. It uses fields that are common to both tables, ie: the Primary key.
A one-to-many relationship is created when a single record in one table is linked to one or
more matching records in related tables. The key in the first table is called the Primary key
and must be unique. They key in the linking table(s) is called the Foreign/External or Other
Key. This is the most common type of database relationship.

To create a one-to-one relationship between two tables, in the Database window go to
Tools>Relationships. The Add Tables dialog box opens and shows the current tables in the
database. Select the first table and click on Add. Move to the next table and click on Add. You will
see a list of fields available for each table. Select the field you are going to link from the first table,
for example Employee ID. Drag this field to the next box and 'drop' it on the identical field in the
second table box. This creates a relationship between the two tables based on the selected field. You
will see a line linking the two tables.
If you are working with several tables it may be easier to move them or change the size. To move
them, click in the grey Title Bar area and drag to a new location. To re-size the table list, move the
mouse over the table border until it changes to a two-way arrow and drag the border left/right or
up/down.
To create a one-to-many link, select another identical field to drag from the first table box to the
next box. When you are finished click on Close.
Delete relationships between tables.
In the Database window, go to Tools>Relationships. Right-click on the relationship line linking the
tables and select Delete.
Apply rule(s) to relationships such that fields that join tables are not deleted as long as links to
another table exist.
Existing relations are shown by a line that connects the primary and other key fields. Once you have
created a relationship you need to make sure that the records are not changed. For example, if a
record is related to another table, and you try to delete it, the program will not allow it. This is
called 'referential integrity'. In the Relations window, go to Insert>New Relations. You can also
double-click on the line joining the fields. A 'Relations' options dialog box opens. The tables used
for the relations are listed at the top under 'Tables involved'. To create a new relation, select the
tables. Under this you will see 'Fields involved'. This displays the key field(s) used for the relation.
Below this there are options to determine the relationship:
Update Options – these are the actions that are applied when the Primary Key is modified.
No Action – if changes are made to a primary key they will not affect the external field(s)
Update Cascade – updates external key field(s) if the primary key is modified.
Set null – when a primary key is modified the value IS NULL is applied to external fields. This
indicates that the field is empty.
Set Default – this allows you to select options to apply when the primary key is modified. The
external fields will be defined by its field properties.
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Delete Options – these are the options that are applied when a Primary Key is deleted.
No Action - the status of external field(s) is not affected when a primary key is deleted.
Delete Cascade – if a primary key is deleted then all corresponding external fields will be deleted.
Set Null – when a primary key is deleted the value IS NULL is applied to all external fields.
Set Default – when the primary key is deleted a set value will be applied to all corresponding
external fields.
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5.3 Forms
5.3.1 Working with forms
About forms
Forms make it easier to read data for each record, as they appear one 'page' or record at a time.
They can be designed with graphics, extra instructions, etc., to make the form easier to work with.
Forms are based on previously created tables.
Open a form.
To open a form you need to open the database which the form was created in. In BASE, click in the
Open an Existing Database file box and select a database from the list. To connect to an existing
database not created in OOo, click on Connect to an existing database and make a selection. Follow
the prompts to Register, Save and Open. In the Database window, click on the Forms button and
then double-click on the file to open it. You can also right-lick on the file to open it.
To open an existing form from other OOo modules, go to File>Open and click on the database
filename. When the Database screen opens, choose Forms and double-click on the name to open it.
Create and save a form.
Either open the BASE module or go to File>New>Database and the Database Wizard will open.
Since you are creating a new form, you need to open an existing database. When the Database
window opens click on the Forms button, then click on Use Wizard to Create Form. The Form
Wizard will open.

Under Tables or Queries, select the table to use to create the form. In Available Fields, select the
fields to use in the form. Click on the field name and then the right arrow (>) to add it to the list.
The double right arrow (>>) will add all the fields. This is the same as adding fields in List view in
the previous section. Click on Next to move to the next screen. This screen allows you to add a
subform. Skip this screen by clicking on Next. (Subforms are not necessary at this stage.)
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You are now at Step 5 in the Wizard – Arrange Controls. Under Arrangement of the main form
there are options for the layout of the form. When you click on one the layout is displayed on a
separate screen under the Form Wizard. You can move the Wizard for a better view by clicking and
dragging on the Title Bar of the Wizard. Select the arrangement you like and click on Next.

In the Data Entry step select the options you want for the form. For example, if others are going to
enter data into this form, you may want to make sure they can't delete any data by selecting 'Do not
allow deletion...' When you are finished, click on Next. Step 7 lets you choose a background style
for the form. The colour you select is shown on the sample form on the screen. Select a colour and
the type of border for the fields. Click on Next.
The final step of the Wizard sets the name of the form. The Wizard will automatically display the
name of the table the form is based on. You can either leave it or click in the box and rename the
form. To begin working with the form, click on Work with form. Click on Finish.
Use a form to enter, modify, delete records.
In the Database window, click on Forms and then double-click on the
name of the form, or right-click and select Open. Click in the field box to
enter or change data. The Tab key will also move you forward to the next
field. To delete a record, click on the Delete Record icon in the toolbar
under the form.
Go to next record, previous record, first record, last record, specific records.
The arrows in the Form toolbar are used to navigate between records. To move forward or
backward one record at a time, click on the right/left arrows. To move to the first or last record,
use the outside arrows.
ICDL & OOo BASE

16

Module 5 - Databases

OpenOffice.org
To search for a specific record, use the Navigator icon (binoculars) on the left of the Form toolbar.
This allows you to search in one or all of the data fields, etc.

To add a graphic to a form, in the Database window open the form in Edit mode. Go to
Insert>Picture>From File and make a selection.
Add, modify text in Headers, Footers in a form.
When you first create the form, only the basic information fields are displayed. You can add
headers and footers to display extra information. You must be in 'Design' mode to make these
changes. From the Database window, select Forms, then right-click on the name of the form and
select Edit. There are two types of headers/footers in forms. The form header shows on each form,
while the Page header/footer only shows in Print Preview or when the file is printed.
To add a form header/footer, in Edit mode first go to View and make sure that the Web layout is
deselected, or you will not see all of your changes. Now go to Insert>Header/Footer>Default.
Type in the text for the header/footer. Format the text as you would in any OOo module. Save your
changes.
Delete a form.
In the Database window, click on Forms to open the list of Forms. Right-click on the name of the
form and select Delete. You will be prompted whether to Delete, Yes/No.
Save and close a form.
To save new data or modifications, click on the Save icon. To close the form, go to File>Exit or
click on the X in the top right corner of the screen. If you have not saved before closing, OOo will
prompt you to Save, Discard changes or Cancel.
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5.4 Retrieving information.
5.4.1 Main Operations.
Use the search command for a specific word, number, date in a field.
Click on the Search icon (binoculars) and enter the search criteria. For example, to find the first
name Jane you would type the name in the text box, then in Where to search, select Single Field and
choose Firstname. Click on the Search button.
In Table mode, the field where the text appears will be highlighted. In Form mode, the record where
the name appears will open.
Apply a filter to a table, form.
A filter lets you work with selected records, based on the criteria specified. For example, you may
wish to only work with records for employees located in one area of a city, so you could filter the
records based on a postal code. There are Filter icons on the Standard Toolbar in Table view or on
the Form toolbar in Form view.
•

•

In Table view, the Standard Filter will open a filter dialog box to let you enter the
search/filter data. When the records are filtered, only the ones with the selected data will
open.
In Form view, click on the Form Based Filters icon, and a blank form will open. Type the
search criteria into the appropriate fields.

Remove a filter from a table, form.
In both Table and Form view the filter icon on the right will remove the filter and all of the
records to be displayed.

5.4.2 Queries
Create and save a single table query, two table query using specific search criteria.
A 'query' is a question. This operation lets you find take specific data from selected tables to create
a report. To create a Query, in the Database window, select Queries. You can create a query using
the Wizard, or create a query in Design mode.
Wizard Queries
To create a query in Wizard, select Queries>Use Wizard to Create Query. Select the table from
the Tables list. Select a field to be searched and click on the right arrow to add it to the Fields in the
Query list. Repeat to add more fields, the click on Next. The next step lets you select how the fields
will be sorted. Click on the drop-down arrow under Sort by and select a field, then select
Ascending/Descending. Add extra sort levels if needed. Click on Next.
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At this stage you can set limits on the records to be displayed. Select a field, a condition and a
value. If you are not creating values the Wizard takes you to Step 7, where you can assign 'aliases'.
An alias lets you change the labels for each field in the query. Skip this step and click on Next. Save
the Query by typing a name in the Name of Query box. Click on Finish.
Design Mode Queries
Click on the Queries icon in the Database window and select Create Query in Design View. Select a
table from the Add Tables box and click on Add. A new box with available fields opens. Doubleclick on the field names you are going to use in the table. In the display at the bottom you will see a
checkmark in each box under the selected fields. To add specific criterion to a search field, enter the
text into the Criterion box under the field name. For example, if you only want to list the employees
who have the last name of Smith, type Smith under the Last Name field. When you have finished
setting up the query, save it, and then click on the Run Query icon on the Standard Toolbar. The
results of the search will be displayed in a table.
To create a query using more than one table, repeat the steps above, but in the opening dialog box
add additional tables to the list. Click on the table name, then double-click on the fields from the
first list to add them to the Query. Repeat this step for each table, until the field names from each
table are listed in the 'Fields in query' list.
Add criteria to a query using any of the following operators: < (Less than), <= (Less than or
equals), > (Greater than), >= (Greater than or equals), = (Equals), <> (Not equal to), And, Or.
When you create a query and specify the Criteria as in the example above, it is the same as using
the = equal) sign. The Last Name field must have the name Smith, ie: Last Name = Smith. Instead
of asking for an exact (=) match, you can use other 'operators' to create a query, similar to using
formulas in spreadsheets.
For example, the table may contain a field for the number of years an employee has worked for an
organization. This might be listed as Employee History in the field name. Use this field as one of
the query fields, and in the Criteria box under it type in the additional query, such as >10. Save the
query and then click on Run Query. The results would display the names of all employees who have
been with the organization for more than ten years.
Edit a query by adding, removing criteria.
In the Database window, click on Queries. Right-click on the name of the query and select Edit. In
Edit mode you can make any changes needed, the click on Save and run the query when needed.
Edit a query: add, remove, move, hide, unhide fields.
In the Database window, right-click on the name of the query and select Edit.
•
Add a field - in the edit window, double-click on the field name in the Table box to add it.
•
Remove a field – in the edit window, click on the bar above the name of the field in the
Field Entries section. Right-click and select Delete.
•
Move a query – in the Edit window, click on the bar above the name of the field and drag it
to a new location.
•
Hide a field – each field in the query has a check box under it, in a row called Visible. While
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•

in Edit mode, if you click to deselect the checkmark, the field will be hidden from view.
This box works as a toggle to show/hide fields.
Unhide fields – in Edit mode, click inside the check boxes to select fields that should be
'visible'.

Run a query.
Once a query has been created you can run it by clicking on the Run Query icon in
the toolbar. If you have left the Design screen you can return to it by right-clicking
on the name of the query and selecting Edit. Use the Run Query icon. The results of
the Query will be displayed in Table format.
Delete a query.
Right-click on the name of the query and select Delete. You will be prompted whether to Delete,
Yes/No.
Save and close a query.
Once you have completed creating a query, click on the Save icon. You will be prompted to give it
a name. Click on Save. To close the query, go to File>Exit or click on the Exit button (X) in the top
right corner of the screen.

5.4.3 Sort Records
Sort data in a table, form, query output, in ascending/descending numeric, alphabetic order.
Data can be sorted into alphabetical or numerical order, and can further be sorted into ascending (AZ) or descending order (Z-A). Note that when you sort data, the Primary key remains with its
original record, so these numbers may no longer appear in order. To sort data in:
Tables - Click on the Sort icon. In the Sort Order dialog box select the Field name and the order to
sort. You can also click on the field heading and click on the Sort Ascending/Descending icons to
perform a quick sort.
Forms - the Sort icons are on the Form Toolbar under the Form. Click on the Sort button and you
will get the same Sort Order dialog box as with tables. Select a field name and sort order.
Query Output – find the field you want to sort and click in the box under it in the Sort row. This
will open a new box with a drop-down arrow. Click on the arrow and choose Ascending or
Descending order. Save and run the query. The records will be displayed according to your sort
criteria.
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5.5 Reports
5.5.1 Working with Reports
Create and save a report based on a table, query.
Reports are used to create summaries of data from tables. Reports are usually created when you
need to print out the results of a query, for example, or to include a summary of data in other
documents. To create a Report, go to the Database window and click on Reports. Click on Use
Wizard to Create Report in the Tasks box. The Report Wizard will open. Click on the drop-down
arrow under Table or Query and select the title of the table or query to use for the report. Next,
select the fields to use in the report. Click on the fields and click on the right arrow (>) until all of
the fields necessary to the report are selected. Click on Next.
The next screen shows how the labels will be displayed. You can change these or leave them as
they are. Click on Next. In Step 3 you can group levels in the report. Skip this step at the moment,
as you will group levels later in this section. Click on Next. If you want to sort the data, for example
by Last Name – Ascending (A-Z), make the selections needed. Click on Next.
In Step 5 you can choose the layout/design of the report. You have options to change the layout of
the data, the headers and footers and also whether to choose Landscape or Portrait style. An
example of the styles chosen will appear in a separate screen to let you see your selections. There
will be text displayed in this window as an example only, this is not the text that will show in the
final report. Once you are finished designing the report, click on Next.
In the last screen of the Report Wizard you will save the report. Give it a name, and then decide
which type of report to create. You have the options of a Static or Dynamic Report. Static reports
keep the information that was originally created for the report. A dynamic report will update
information if the data the report was based on has changed. By default the button for Create report
now is selected. Click on Finish and the report will be created and opened.
Change arrangement of data fields and headings within a report layout.
It is easier to make changes to the arrangement of data fields/headings in a report when you are
creating it. In Step 1 of the Report Wizard (Field Selection) select the fields for the report, and in
the Fields in Report box, select a field and then use the up/down arrows to move it to change the
arrangement. Repeat this step until the fields are in the correct order for the report. Continue
creating the report. In the last screen (Step 6), select Modify Report. Click on Finish. You will be
able to modify the page design, text formatting, column widths, etc. using text, page and table
formatting features. Save your changes.
To make changes to an existing report, go to the Database window, click on Reports and right-click
on the name of the report, then select Edit. The report will automatically open in Writer, because it
is treated as a text document. You can make changes to the design as needed. Remember that it is in
a table format. You will need to make changes to it using methods for creating tables in Writer. For
example, to move a column, you will need to Insert a column where the new column will go. Then
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select the column to move. Right-click on the field name and select Column>Select. Using Cut and
Paste, move the column to the new location. Return to the empty column, right-click and select
Column>Delete to remove the empty column. Continue as needed. To change any text in the
headers, click in the cell and make changes. Save your changes.
Group data under a specific heading (field).
While creating a report, you will be prompted to 'group' data in Step 3 of the Report Wizard. You
will sort or group data based on the values in one or more fields. For example, if one of the fields in
the report is 'City', you may want to group the results by this field. You can add four groups to this
box. When you click on Next, the Sort Options will automatically show that the results will be
grouped by City, and then by any other choices you have entered into the group box. You can select
Ascending or Descending to change the results. When the report is finished, results will be
displayed first by City, then any other fields selected for the group, then will display the remaining
field selections.
Present specific fields in a grouped report by sum, minimum, maximum, average, count, at
appropriate break points.
In the Database window, select a query which you have created. Right-click and select Edit. In the
list of options under the table selection area you will see Functions. Click in the Function cell under
each field to set the function required. (The Function field will appear empty until you select it.)
When you run the query each function that you set will be activated. If 'Function' is not listed under
the fields, click on the Function icon in the Toolbar to activate it.

Add, modify text in Headers, Footers in a report.
To modify any text in Headers or Footers in an existing report, right-click on the report name in the
Database window and select Edit. Make changes and save.
Delete a report.
In the Database window right-click on the report name and select Delete.
Save and close a report.
Click on the Save button and then click on File>Exit or use the Exit (X) button in the top right
corner of the work screen.
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5.6 Prepare Outputs
5.6.1 Prepare to Print
Preview a table, form, report.
To preview a table, form or report, first open it and then go to File>Print Preview. Click on Close
Preview to exit this mode.
Change report orientation: portrait, landscape. Change paper size.
In the Database window right-click on the report name and select Edit. In edit mode (Writer), click
on Format>Page>Page and make any necessary changes.

5.6.2 Print Options
Print a page, selected record(s), complete table.
In order to print a selected range of records or a complete table, you first need to open a text
document. Reduce the size of the window. Go to the Database window and select Tables. Reduce
the size of the window. Click and drag on the table name to bring it into the text document. This
will open the Insert Database Columns dialog box. Select the fields to include. Click on Autoformat
to select a formatting style. Close the dialog box. Save and then go to File>Print.
You can also create a report based on the records/table and then go to File>Print>OK. There is no
print option in the Table window.
Print all records using form layout, specific pages using form layout..
Open the form from the Database>Forms page. Go to File>Print and select All to print all of the
forms, or select Pages and type in the selected range of records. Click on OK.
Print the result of a query.
To print the result of a query, first you need to open a text document. Reduce the size of the
window. Go to the Database window and select Queries. Reduce the size of the window. Click and
drag on the Query name to bring it into the text document. This will open the Insert Database
Columns dialog box. Select the fields to include. Click on Autoformat to select a formatting style.
Close the dialog box. Save and then go to File>Print.
You can also create a report based on the query and then go to File>Print>OK. There is no print
option in the Query window.
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Print specific page(s) in a report, complete report.
Open the report and go to File>Print. To print the full report, select 'All'. To print a selected range
of pages, type the page or range of pages into the Pages dialog box. Click on OK. In order to print a
selected range of records, you first need to prepare a report based on the selected records. Once it is
created, go to File>Print>All.
Print to file.
In some cases it may be necessary to “Print to file”, where there is no printer available or in a
classroom situation, for example. Go to File>Print. Select Print to File. Select a destination for the
file. When you save the file it will have a .PRN extension.
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Database Vocabulary
AND – used to search a database for records matching two statements or criteria.
Arrange (Sort) – to re-arrange records in numerical or alphabetical order in ascending/descending
order.
Ascending - a list in A-Z order or from smallest to highest number.
Columns – each column in a database is a separate field and the field name appears at the top of
each one. Any attributes assigned to that field will appear in each field under it.
Connectors – words used to search databases, such as OR or AND.
Data – information.
Database – a collection of data, such as a telephone directory.
Descending – a list in Z-A order, or from highest number to smallest.
Editing – to make changes to the information or design in a database.
Enter(ing) – typing information into a database.
Entry – the information in a field or record.
Field – information in a database is arranged in categories which are called fields.
Field Properties – attributes which are specified for each field. For example, in a field for telephone
numbers you could specify that only numbers are entered, or you could determine field size for
entries to restrict how many characters can be entered in each cell in that fields.
File – a database is called a file and is listed with other files on a computer or in external storage.
Find (Search) – to locate specific information which matches the search criteria. See Search below.
Forms – these are used for data entry in a display where you only view one record at a time, similar
to creating one page for each record. In a table records are viewed as a list.
Indexes – a method of using a specific field for information which is used to located data. A
primary key is a form of index.
Keywords – descriptive words used to specify sort criteria, such as: largest, smallest, least, most,
etc.
Match – information which satisfies the search criteria.
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Operators – words or symbols used in formulas or searches, such as > (greater than).
OR – a 'connector' used in a database search which indicates that for two statements/criteria any
records that match either one or both statements are to be selected.
Primary key – a field used to identify each record with a unique value.
Queries – a question formed to search for specific data in a table to create a 'subset' of data.
Record – each row in a database table is a record. Records are made up of a series of fields and
show all of the related information for an individual item or listing. Each record is unique. In a
telephone directory, for example, each listing of a person's name, address and phone number is a
record.
Relational database – a system where related data is stored in separate tables.
Report – the results of a search showing records which match the search criteria. These can be
printed or displayed on screen.
Row – a row is a record in a database, reading from left to right. Each row/record represents an item
in the database and its related information.
Search – to locate specific information which matches certain statements/criteria. This is also called
Find, Query, Filter or Match.
Sort – a function which arranges records in alphabetical or numerical order in ascending or
descending order, based on selected fields and keywords.
Tables – data is stored in tables consisting of a series of records. In order to create Forms, Queries
or Reports, data must first be entered and saved in a table.
Template – a pre-formatted design or form which is used for each record in a database.
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